1. Welcome to CAST's newly designed and improved Forum

    Log in or Sign up and share the knowledge!

    Dismiss Notice

More info when not being able to connect

Discussion in 'Technical Support' started by Martinus Magneson, Nov 8, 2017.

  1. Martinus Magneson

    Martinus Magneson New Member

    Joined:
    Feb 23, 2017
    Messages:
    7
    Likes Received:
    0
    I'm having issues connecting to MA2 via the proper protocol. The only information that pops up in wyg is "Could not connect to the following console(s): grandMA 1." Wygalizer works fine, but then I have to pop out a command wing or a console, which can be a bit of a hassle.

    It would be benefcial to have at least a pointer to why this is, like naming errors, adress faults , patch errors or something like that.

    Ideally, wyg should list available consoles to start with, and push/pull info to/from the consoles - but as a lesser alternative more info when it doesn't work would help a lot.

    If anyone have a better insight as to why I can't seem to connect I'd also appreciate that. I use wyg2ma before connecting, have checked naming and addresses multiple times, and also tried both localhost and my network IP as the interface.
     
  2. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    46
    Likes Received:
    2
    More often than not its usually the MA side of things that cause the non connection.

    I have a habit now to just leave Wyg enabled option on the MA2 on and I'll turn it off if issues arise on site. this leave it so the only other issue would be which IP zone you are using.
    I have 3 networks setup in my office. 1) Web (which I keep away from my lighting computers the best I can) 2) Console line which I use as MA mode or Hog Mode or what ever console comes into the office. and 3) Art-net line. All under different IP Ranges. so I know all my MA stuff should talk either in the 192.169.#.# and my art net is 2.10.#.# ranges. in the GMAWYG driver I just leave it setup as grandMA 1 - 192.169.#.# and if it doesn't connect it's usually due to me setting the MA into 127.0.0.0 mode. so just switch the MA to right port and done.

    What I'm getting at is yes. it be great if the old auto patch to console was still alive and well. but from what I recall it was up to the console manufactures to implement which they seem to have dropped all together, as the option to auto-patch is still there in wyg. Not to mention a few chats with Dany and Dino at Cast confirming this. Even still you need to have the initial communication between the two setup. so you be right where you are now.

    You just need to put a system in place so that your list of reasons for not connecting is one or two things.. not a list of 20 things. Then like me if its something that used on every file make a template file with the setting already saved. I will say right now I spend about 2 minutes on the setup of my MA/Hog/Chamsys systems to Wyg. All I really do is just enter where the ABC of line match in wyg which is often just a 1 to 1 patch. and yes I do use the Wyg2ma application as well to help with the rest. but thats more because I'm lazy with that stuff on the ma.

    Then like any troubleshooting in the lighting world.. it all could just be that damn silly tab missing on the Ethernet cable and it slipped out for some fresh air ;)
     
  3. Dino

    Dino Dino Mazza | Product Manager | CAST Software

    Joined:
    Jan 16, 2014
    Messages:
    103
    Likes Received:
    2
    Hi Guys,
    Here are a few things to look for when connecting WYSIWYG to the MA Consoles:


    On the MA Console:


    1. In Settings> Global Settings, ensure you have the WYSIWYG setting ON.

    2. In MA Network Control, ensure the Station IP is set to the correct IP Address. If not, set it in the dropdown and restart the console.

    3. Set the Session ID as desired, and make note of it.

    4. Create a Session.


    On the Computer running WYSIWYG:

    1. If you are using a real console or running MA onPC on a different computer, ensure you can ping the console/computer it is running on from the Computer where you have WYSIWYG. If you cannot, please turn off your firewall or whitelist, allow WYSIWYG Application for public and private networks.

    2. Ensure you have the correct WYSIWYG Connectivity Driver installed, version 2.900-6.800-v1.220

    3. Ensure that the MA-Net Mode is set correctly; if you are using MA2 you must use MA-Net2, if MA1 you must use MA-Net.

    4. Ensure that you have the correct Station IP Address listed in the MA-WYG Driver dropdown.

    5. Ensure you have listed the Session ID that you will be using, e.g. 1

    6. Start WYSIWYG, and patch your universes to the Port numbers in the grandMA console device.

    7. In the Address, type in "grandMA 1" if you are using session ID=1.

    8. Click Connect, and if all settings are correct, WYSIWYG will connect to GrandMA console.

    Hope this helps!
    Dino
     
  4. Dany

    Dany Super Moderator

    Joined:
    Jan 16, 2014
    Messages:
    545
    Likes Received:
    22
    Hello everyone,

    To complement Dino's troubleshooting steps above, here are some marked-up screenshots which should also help you through the connection to the grandMA 2. (Yes, the WYSIWYG screenshot is a bit old. :rolleyes:)

    Cheers,

    Dany

    ~~~

    gMA2 - connected.png

    ~~~~

    gMA2 - global_settings.png

    ~~~

    gMA2 - network_protocols.png

    ~~~~

    gMA2 - network_setup.png
     

Share This Page