1. Welcome to CAST's newly designed and improved Forum

    Log in or Sign up and share the knowledge!

    Dismiss Notice

Resolving WYSIWYG Startup Errors

Discussion in 'Technical Support' started by Dany, Aug 11, 2017.

  1. Dany

    Dany Super Moderator

    Joined:
    Jan 16, 2014
    Messages:
    679
    Likes Received:
    64
    A number of users have experienced the following errors when attempting to start WYSIWYG:

    Sentinel LDK Protection System: Sentinel key not found (H0007)

    or

    Unable to access Sentinel Run-time Environment (H0033)

    To fix this problem:
    1. Click the Windows Start menu, type services.msc and press <enter>. [The Services console appears.]
    2. Ensure that the Services are sorted by name and scroll down to the S section.
    3. Four Sentinel services are listed here, and there is a good chance that the one called Sentinel LDK License Manager** is not running (but the other three are). [You can see this in the Status column.]
    4. Right-click on the one that is not running and select Start from the menu that appears.
    5. Wait for the Status to change to Running.
    6. If necessary, repeat steps 4 and 5 for any of the other services which are also not running.
    Now R41 should start without problems.


    ** If you do not see the Sentinel LDK License Manager service in the Services console, it was probably blocked from being installed together with WYSIWYG by your anti-virus software or some other system protection utility (such as, but limited to, Windows Defender or Windows Firewall), so you have to install it manually, as follows, once you have disabled any and all anti-virus and/or other system protection utilities:
    1. Copy the following text, complete with the quotes: cd “C:\Program Files (x86)\CAST Software\WYSIWYG Release 41\Bin\Sentinel”. IMPORTANT: If you are using a different version of WYSIWYG, replace 41 with your Release number.
    2. Click the Windows Start menu and type cmd
    3. Do not press <enter>. [A Command Prompt entry appears at the top of the menu.]
    4. Right-click on Command Prompt and select Run As Administrator.
    5. Accept the security warning. [The Command Prompt window appears.]
    6. Right-click to paste the text copied in step 1. (above here), then press <enter>.
    7. Type haspdinst.exe –i and press <enter>. [Your anti-virus or other system protection utility may attempt to block the installation. Ensure that this doesn’t happen either by getting the utility to allow the installation to proceed, or by turning it off altogether.]
    8. Wait for the command to complete, and click OK to close the “success” message that appears once it’s done.
    9. Restart your computer.
    Back on the desktop, run WYSIWYG. If the same error appears, perform the first set of steps above (1 through 6) and then run WYSIWYG.

    If it still doesn't run, create a rule/exception for wyg.exe and hasplms.exe in your anti-virus/firewall/system protection software. (You may need to contact your IT team for information on how to do this, if you do not know how or if you do not have the necessary permissions on your computer to perform this task.)

    The paths to the .exe’s are:
    • C:\WINDOWS\system32\hasplms.exe
    • C:\Program Files (x86)\CAST Software\WYSIWYG Release 41\Bin\wyg.exe. IMPORTANT: If you are using a different version of WYSIWYG, use its Release number for this path, instead of 41.

    Should you continue experience problems with this, please contact our technical support department for further assistance.
     
    #1 Dany, Aug 11, 2017
    Last edited: Nov 15, 2018
  2. NickF

    NickF New Member

    Joined:
    Jun 8, 2018
    Messages:
    3
    Likes Received:
    1
    I thought I would add something to this topic in case someone has a similar issue where the mentioned procedure on this page does not work for them.

    I recently had a similar issue with my Wyg dongle. I got the message Sentinel LDK Protection System: Sentinel key not found (H0007)
    I tried to fix it using the step by step in this post, unfortunately it did not work.
    I then did a conference call with CAST and GEMALTO. The Gemalto technician ended up being able to fix the problem. He remoted in to my computer and had to install a cleaning tool to get rid of the error. Following the procedure, everything worked well.
    Today I got the same error message on another PC that I owned and will probably have to do the same procedure but at least there is a solution which does not imply re-installing Windows completely as some people had to do. Anyway, I hope this helps in case someone has a similar issue. I believe Darren from CAST was part of the conference call so he might be a good resource if you come across something similar.

    Thanks CAST and Gemalto for the help! cheers
     

Share This Page