1. Welcome to CAST's newly designed and improved Forum

    Log in or Sign up and share the knowledge!

    Dismiss Notice

Sluggish right click menu with LED wall

Discussion in 'Technical Support' started by Martinus Magneson, May 15, 2017.

  1. Martinus Magneson

    Martinus Magneson New Member

    Joined:
    Feb 23, 2017
    Messages:
    4
    Likes Received:
    0
    Hi

    I'm using the Blackmagick DeckLink 4K Pro for video input, set to 720p. GTX1080 gfx card, 32GB RAM, and i7 6700k processor.

    When having a shaded view displaying the LED-wall with video input containing subsources, the right clik menu fades very slowly in before being able to use it. This also happens in the sub menus. Using shortcuts like Alt-Enter for properties seems to open immedeately. Is there a way to disable the menu fade somewhere in the software (all visual fx in Windows is disabled)? I looked the obvious places, but I might have missed a clue.
     
  2. Michael Ang

    Michael Ang Super Moderator
    Staff Member

    Joined:
    Feb 21, 2017
    Messages:
    10
    Likes Received:
    0
    Hi Martinus,

    We do not support the Blackmagic DeckLink 4K Pro, as we have not tested it on WYSIWYG. If your right-click menu is opening slowly in shaded view, that means your shaded view performance is taking a hit, either from what is inserted in your file or because you're connected to a capture device.

    Below is a link of a resource on our website on how to improve performance in shaded view:
    http://www.cast-soft.com/tipsandtrics/improving-performance-in-shaded-view-2/

    You can find all the supported video capture devices for WYSIWYG here:
    http://forums.cast-soft.com/index.php?threads/video-capture-devices-for-wysiwyg.315/

    Regards,

    Michael
     
    #2 Michael Ang, May 15, 2017
    Last edited: May 15, 2017
  3. Martinus Magneson

    Martinus Magneson New Member

    Joined:
    Feb 23, 2017
    Messages:
    4
    Likes Received:
    0
    Thank you for the swift reply Michael!

    I have to the best of my abilities followed the reccommendations for WYSIWYG, and overall it is a mostly smooth experience. The simulation in itself (and the video input) don't seem to behave sluggishly, it is only the menu fading. The capture card also works fine (although unsupported), and I've built several other stages where this hasn't been a problem, but where I have used projection mapping instead. Using the shortcut keys (Alt+Enter, V, Ctrl-G) behaves as expected without delay, and the menu seems to be working just fine as long as the fading is done. The menu fading is also sluggish in wireframe view as long as a shaded view is open (either in a pane or separated pop-up frame).
     
  4. Michael Ang

    Michael Ang Super Moderator
    Staff Member

    Joined:
    Feb 21, 2017
    Messages:
    10
    Likes Received:
    0
    Hi Martinus

    As I said in my previous post, it could be because of what's inserted in your file, probably the LED Walls if you made a lot of them.

    The only way for us to do further investigation on this is if you email us your file. Our email address is techsupport[at]cast-soft[dot]com.

    Regards,

    Michael
     
  5. Nick

    Nick New Member

    Joined:
    Jul 28, 2017
    Messages:
    2
    Likes Received:
    0
    I am also having the same problem. When there is a video playing on a surface, the right click menu is VERY slow to fade in.... and you must wait for it to complete it's "fade" before you can click on anything.
     
  6. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    43
    Likes Received:
    2
    I've been chatting with the guys at Cast about this for a bit now. It is something they are working on. It is tied to having a lot of action happening in the shaded view. i.e.video walls, ton of led fixtures etc.

    Nick I know you been using capture cards as well and it may be tied to something dealing with capture devices but it may be as silly as a video driver issue. Nick and Martinus are you both using NVidia cards out of curiosity?

    I can't say when issue will be fixed. but I have been talking with them this past few weeks as it's been popping up with some other drawings as well.
     
  7. roygbiv

    roygbiv Member

    Joined:
    Feb 6, 2014
    Messages:
    129
    Likes Received:
    10
    I've experienced the same issue on multiple occasions, however this has not had anything to do with video input.
    The issue occures, with a lot of complex geometry - big Sketchup or Rhino3D imports.

    In my case, it's "just" a question of cleaning up the drawing, or turning of layers.
    But of course, if the menu popups and application tasks was not touched by the content of the drawing, that would be great :)
     

Share This Page