1. Welcome to CAST's newly designed and improved Forum

    Log in or Sign up and share the knowledge!

    Dismiss Notice

Video Capture Devices for WYSIWYG

Discussion in 'Technical Support' started by Dany, Feb 19, 2014.

  1. Dany

    Dany Super Moderator

    Joined:
    Jan 16, 2014
    Messages:
    658
    Likes Received:
    61
    In order for video capture devices to work with WYSIWYG, their driver must be of the Windows Driver Model (WDM) type. Therefore, in theory, any such device which uses such drivers should work but not all do. As such, we are unable to officially support any capture cards which we haven't tested ourselves--and we strongly advise against purchasing a video capture device that is not listed below. (In case you do wish to purchase a device not listed below, information regarding the type of driver that it uses should available from its manufacturer.)


    Here are the capture devices which CAST Software has tested and therefore recommend and support for use with WYSIWYG; this list will be updated once more devices are tested.

    The following are expansion cards which require a PCIe slot (running at x4 minimum):

    • the AVerMedia DarkCrystal HD Capture Pro; AVerMedia’s part number for this is MTVHDDVRR, the model number is C027; input options are HDMI, Component, S-Video and Composite
    • the AVerMedia Game Broadcaster HD; AVerMedia’s part number for this MTVGBCAST, the model number is C127; input options are HDMI, VGA and Component
    • the DataPath VisionRGB-E1/s** or VisionRGB-E2/s**; the only input option on these is DVI
    • the BlackMagic Design Intensity Pro and Intensity Pro 4K; input options are HDMI, Component, S-Video and Composite
    ** IMPORTANT NOTE: In order for the DataPath cards to work properly, their driver must be installed with the Kernel Streaming option, NOT with the User-Mode Streaming option; installing the User-Mode Streaming driver will result in the video appearing upside-down in WYSIWYG.


    The following are USB devices:

    • the AVerMedia DVD EZMaker 7; AVerMedia’s part number for this MTVDVDEZ7, the model number is C039; input options are Composite and S-Video
    • the BlackMagic Design Intensity Shuttle for USB 3.0; input options are Composite, S-Video, Component and HDMI; ONLY works when connected to a USB 3.0 port; it is important to note that WYSIWYG only supports the USB 3.0 model (and not the Thunderbolt model)

    The AVerMedia and BlackMagic Design cards/devices are single-input. The DataPath-E1 is a single-input card and the -E2 is dual-input; if needed, multiple DataPath cards may be used in one system, and the limit is the number of PCIe slots (again, x4 is the minimum) available on the motherboard; to use multiple such cards with WYSIWYG, they must be installed in the computer one by one.


    Cheers,

    Dany
     
  2. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    80
    Likes Received:
    5
    Lol wish this was out there a few months back.

    If I wasn't busy with work I still love to stop by the office and chat with Gil on what I found and how it's been working for me.

    I went with the BlackMagic Design cards. I have 2 x Intensity Pro PICe; 1 x Decklink Duo and an Intensity Shuttle 3.0. I also use these cards for my Arkaos video server as well which was how I discovered the BlackMagic line.
    I have to say the Intensity Pro cards are a great price point and work with great results. The Decklink is a SDI format and does work well but better suited for servers equipped with SDI or Cameras inputs. The Shuttle USB 3.0 is good for external but beware of the USB 3.0 specs. It can be very picky to it's needs. I also find it does create some lag between source and playback. compare to the PICe cards. The software is all the same Decklink and you can change settings between different cards very easily in the windows control panel.

    I also have a AVerMedia Live Gamer capture but find it was buggy and just use it on my older laptop to keep resources low and often with low video res.

    Congrats on the new forum. I am sure it will serve as a good resource for Cast Users.
    Jason Gardash.
     
  3. toto

    toto New Member

    Joined:
    Feb 10, 2014
    Messages:
    1
    Likes Received:
    0
    Wysi video setup

    Hello, I was watching the advance in videoservers and I think that compared to other programs visualization example light converse, Ai Avolites, from the point of view of a lighting programmer I think that working with video in WYSI is not so easy, I would like it was a little easier, more practical, less technical ... what you guys think?, Greetings
     
  4. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    80
    Likes Received:
    5
    Hey Toto,

    My take of video in lighting programs is that it should become something to have. But even with some difficulties of video setup in Wyg. It is pretty cut and paste. With the shaded views and beam improvements I do hope that Cast will focus on some video components next as I do think video has become part of any med to large show designs.

    The post with a list (even if short and brief) of video capture cards is a good move. something that I wish was also on the technical web site as well. This would of been a helping hand when I updated my system this past winter. but I am use to trouble shooting and testing new systems out so I enjoyed the experience of learning the workings of it all.

    I would like to see if it could be possible to look at video walls and maybe even come up with a library of wall's that can be built and move away from the led wizard. But that's Just due to the fact I like to see and build with gear at spec. But I would understand that it will also be harder to incorporate and keep tabs on.

    I've had a few people over to see the new setup and video interaction. and had some good comments on it. I'm sure as time goes on the integration of video will become easier and more real world. But Just a few guys working on a few programs so just need to give them time to make it all happen.

    Jason.
     
  5. olivlite

    olivlite New Member

    Joined:
    Feb 28, 2014
    Messages:
    2
    Likes Received:
    0
    Tried with the black magic Decklink HD extreme, and it doesn't work. Wysiwyg can see it, but nothing happens.

    Olivier
     
  6. olivlite

    olivlite New Member

    Joined:
    Feb 28, 2014
    Messages:
    2
    Likes Received:
    0
    Tried with the black magic Decklink HD extreme, and it doesn't work. Wysiwyg can see it, but nothing happens.
    Dany, the links for Dark Crystal, doesn't work.
    Olivier
     
  7. Dany

    Dany Super Moderator

    Joined:
    Jan 16, 2014
    Messages:
    658
    Likes Received:
    61
    Hi Olivier,

    I just fixed the links--thanks for the heads-up on that! (It's very weird that they didn't work because I ended up replacing them with the exact same links! :confused: Anyway.)

    Sorry to hear that the DeckLinkHD Extreme capture card didn't work, but as I mentioned, it is not one that we ever tested, so we cannot support it. Maybe Jason can offer some tips (although you will note that the devices he mentioned above are different than yours.. they're from the same family though, so I can't imagine them being THAT different..).

    Sorry I can't help more myself, but I guess this is why it's so great that we now have a forum where users can share this kind of information..


    Hope it works out for you,

    Dany
     
  8. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    80
    Likes Received:
    5
    Hey Olivier,
    I ran into this as well.
    there are two drives that pop up under wysiwyg and a setting in the control panel under the windows / system / Blackmagic driver settings.

    I am not in front of my settings as I am out on tour right now but I will do my best to recall the settings.


    in the settings panel. under video setup the default is 7.5 ire usa change this to 0.0 ire japan I know it seems odd but that was the major change that let Wysiwyg see the driver and video input.

    in wyg select The non blackmagic driver if I recall directly.
    here is the support file which helped me a fair bit. but some of it was pure luck. as long as your under the decklink drivers all the intensity and HD extreme cards should work the same.

    here is the support link
    http://images.blackmagicdesign.com/media/8755532/Desktop_Video_Manual_Mar_2014.pdf

    again I'm away from my office but if your still having issues and I can have a mate take a look at the setting for me. or get back to you when I return at the end of April.

    Jason.
     
  9. denishessberger

    denishessberger New Member

    Joined:
    Aug 20, 2014
    Messages:
    3
    Likes Received:
    0
    Yes, they do actually work. Also make sure to set the right input settings in the Blackmagic utility, eg in the BlackMagic Express Capture tool installed with the drivers.
    I've used Decklink Studios and Intensity Pros and they all work. However, be aware that the Intensity Pro needs overscan do be active in the device that is outputting to the card.
     
  10. ben

    ben Member

    Joined:
    Feb 6, 2014
    Messages:
    119
    Likes Received:
    10
    hello I' ve read on a french web site, who sell Blackmagic Design Intensity Shuttle USB 3.0'

    INFORMATIONS FOURNIES PAR NOTRE SERVICE TECHNIQUE :*Blackmagic Design Intensity Shuttle USB 3.0 est UNIQUEMENT compatible avec les appareils équipés de contrôleurs USB 3.0 basés sur un chipset NEC.

    it only works on Pc with nec usb 3 chipset So HOW I know if my USB 3 chipste is a Nec one ?
    Thank's

    http://www.ldlc.com/fiche/PB00119260.html
     
  11. Dany

    Dany Super Moderator

    Joined:
    Jan 16, 2014
    Messages:
    658
    Likes Received:
    61
    Check your motherboard manual, if you happen to have one. If that doesn't provide the information, or if you don't have one because you didn't custom-build your computer, you should be able to find out from the motherboard's or the computer's manufacturer.

    Good luck,

    Dany
     
  12. ben

    ben Member

    Joined:
    Feb 6, 2014
    Messages:
    119
    Likes Received:
    10
    OK I will have a look on MSI website...
    But do you know something about this limitation ?

    thank you !!!
     
  13. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    80
    Likes Received:
    5
    Hey Ben,

    I use a MSI Laptop for some Media Master Pro stuff and I can get the shuttle 3.0 to run off that. Just make sure you are in the USB 3.0 port (most often over looked part).

    In terms of needing a certain chip set. when I had setup my main Wyg system last winter. I spent a fair amount of time looking at different USB 3.0 cards and after a few I did find one that did work but funny enough the one that was on my motherboard had a faster response time. I had researched the boards chips but in the end when it came to motherboards and USB PICe cards I had better luck finding the chip sets for the PCIe card than on a motherboard.

    In the end I just tell people it's a bit of trial and error but do the research and you can make it work without much issue.

    If you don't have the right chip set the device will load but the drivers won't find the device with full use. often with me it would list the device but then would drop out after a few minutes.

    It kind of took me back to the old latency days of sound cards and internal hardware of the Pentiums computers.

    The other choice and I do often is try to find someone or a shop that will let you try running a Shuttle 3.0 on your setup. I have taken my shuttle to a few places now to test run their setups and see if it will work or not. to date it's been a 50 - 50 success. From the feedback I gotten though. it did save countless hours of trial and error.

    If the Shuttle did not work and they are on a PC with a open PCIe port they often get the intensity Pro card.

    Jason.
     
  14. ben

    ben Member

    Joined:
    Feb 6, 2014
    Messages:
    119
    Likes Received:
    10
    Thank's Jason, I will find a shop where I could test a shuttle 3.0 on my laptop...
     
  15. jacklampy

    jacklampy New Member

    Joined:
    Apr 19, 2015
    Messages:
    8
    Likes Received:
    0
    Hello All.

    I just got a BlackMagic Intensity Shuttle USB 3.0. I was having the worst time getting it to work. I finally got it to work with the Desktop Video Version 10.2.2. Everything else was making it my brand new computer crash. BlackMagic was telling me to use 10.3.7 or 10.4.1, and Cast was telling me to use 10.1.1, but none of these were working for me. I just sat and tried every version between the 2 I was told until 1 worked.

    Everything needs to match on both machines. And the one I was told that I got working was HDMI input with the resolution of 1080p at 24 hertz or frames. But nothing was stable until I got to that version with the proper drivers installed.

    I hope this helps for anyone trying to use that BlackMagic Intensity Shuttle.

    Now if anyone knows how to scale it down to not just be full screen I would love the help. Thanks in advance.
     
  16. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    80
    Likes Received:
    5
    Hey Jack,
    There is something a miss with the newer BlackMagic drivers I assume it may have to deal with the new line of 4K cards which use these drivers.
    On my machine I need to set the BlackMagic Driver to HD 720P 60 with At 0.0 IRE selected and the Media Server set to 1280x720 to get any response. I am currently using the 10.2.2 drivers as well.
    I don't update the capture Drivers often. why fix what is not broke. but I was playing around with the newer ones last week as I was testing a new system out and noticed the no responsive to wysiwyg.

    I know the guys are re-looking at the Capture drivers so hopefully soon there may be a fix but it may take a few weeks.
    There may be an underline issue as well with the system setup as I know with me even with different Drivers my system didn't crash it just wouldn't give me any input to Wyg but I could still capture using BlackMagic Media Express that loads with the drivers. Make sure you have all the Power management boxes unchecked under the USB Root Hub and power management in the device manager settings. This will also cause some issues as well with the Shuttle USB 3.0

    Are you referring to scaling down inside Wysiwyg or from your source? I generally scale down from the source and try to match the Wyg Video manager to the closest rez your looking for. For me I keep Wyg at 1280x720 as this is the only setting I could get to capture at. But I will see what happens when I try the setting you use.

    Jason.
     
  17. Derek Welker

    Derek Welker New Member

    Joined:
    May 26, 2016
    Messages:
    7
    Likes Received:
    2
    I know this thread has been static for quite some time but I wanted to post in here to let everyone know that I just purchased an Avermedia Dark Crystal Pro C027 and will be sharing my results once I receive the product. We tried CITP streaming and for the size of our screen and the resolution limitations of CITP we are going to give the capture device a try.
     
    Carlos and ben like this.
  18. Elie

    Elie New Member

    Joined:
    Jun 30, 2016
    Messages:
    5
    Likes Received:
    0

    Hello Jason

    Please can you help me to set windows with BlackMagic shuttle intensity USB 3.0 with Wysiwyg ??

    i installed it on windows 10 ,64bit by Usb cable and to the Black magic input it was connected to HDMI and the video signal comming from my Macbook from Thunderbolt output to HDMI input in Black magic and i can see on my pc the video .
    but after setting in Wysiwyg and can see it in the capture device and connected it and everything is ok .

    the main problem is nothing displaying in the shaded view from the projector ..

    what is the problem ? and how i can solve it ?

    Thank you

    Elie
     

    Attached Files:

  19. Jason Gardash

    Jason Gardash Member

    Joined:
    Feb 5, 2014
    Messages:
    80
    Likes Received:
    5
    For Blackmagic driver settings I have are set like the setting.jpg photo.
    make sure you are using the black Magic WDM capture driver and not the Decklink Video Capture in wysiwyg. with the same resolution setting at the Blackmagic driver setting in photo.

    I do know that the USB 3.0 chip-set on your motherboard needs to be a certain one and it is picky. if you can see an image on the native Black Magic Media express program than you should be good. if you don't get or see any image within that then it may be a chip-set issue.

    Not in-front of my system right now but this is the usual cause of issues (drivers settings)
    I have not tried using the capture with windows 10 as of yet.
    also to note. I use drivers 10.2 on Main and 10.6.2 on my Laptop. I just found 10.2 worked and was stable there were a few versions 10.3 - 10.5.2 that gave issues working with Wysiwyg.

    Jason. settings.jpg
     
    Elie likes this.
  20. Elie

    Elie New Member

    Joined:
    Jun 30, 2016
    Messages:
    5
    Likes Received:
    0
    Hey Jason
    thank you a lot for your answer
    i can see image on my desktop black magic express and i set it the same resolution in wysiwyg and blackmagic but still doesnt display the image in shaded view ...
    Elie
     

    Attached Files:

    • bm.png
      bm.png
      File size:
      341.5 KB
      Views:
      632

Share This Page