1. Welcome to CAST's newly designed and improved Forum

    Log in or Sign up and share the knowledge!

    Dismiss Notice

Video Capture Devices for WYSIWYG

Discussion in 'Technical Support' started by Dany, Feb 19, 2014.

  1. Dany

    Dany Super Moderator

    Joined:
    Jan 16, 2014
    Messages:
    657
    Likes Received:
    61
    Thanks for all the information you sent David!

    There is no need to apologize.

    I’ve been testing all this for the past two days with all possible combinations of multiple computers, multiple drivers, and both R39 Update and R40, and my conclusion is that while I DO get the problem you are describing, it is absolutely random.. I can close and open my test files multiple times without issues, close WYSIWYG and even restart the computer and it’s fine, but then the next one or two or three times I do this (not necessarily consecutively, and, again, the number is completely random) I get the error. It follows no pattern that I can discern, and it happens regardless of whether I am using a single Video Source or multiple Video Subsources.

    Fortunately though, there is a very easy workaround for this, which works one hundred percent of the time whenever the “can’t connect” error appears:
    1. Go to the Video Manager.
    2. Select the Video Source you created (not any of the Subsources).
    3. Click the Options button (the gear at the top of the Video Manager window). >> The Video Source window appears.
    4. Ensure that the “Blackmagic WDM Capture (x)” option is selected in the Video Capture dropdown; “(x)” can be any number—and I will explain this below.** (The number will be different than before, but that doesn’t matter, since it’s the same ‘source’.)
    5. Click OK. >> A warning appears regarding the dimensions having changed. Simply click OK and ignore it: despite what it says, since the resolution of the incoming video is the same, it will not affect your Subsources in any way.
    6. Click OK to close the Video Manager.
    The video stream should now come through.

    ** The number is assigned to the BM Intensity Shuttle device by Windows (not WYSIWYG—this is in answer to your assumption that WYSIWYG keeps some kind of log here) every time the device connects and disconnects from the system. I do not know what would cause these disconnection/reconnection events, but they clearly happen, and, again based on all the testing I’ve done, they do not seem related to WYSIWYG (just like WYSIWYG doesn’t assign the “device number”). I do not know what criteria Windows uses for this, nor do I know why it does this—that is something that our developers will have to figure out.


    Naturally, I have now flagged this issue, and Soft. Dev. will look into fixing it as soon as possible. However, if it stems from Windows itself, and cannot be worked around, the fix may have to come from Microsoft in a Windows Update. I will post another message here when I have more news about this. In the meantime though, the procedure above, while I understand it is not ideal, is the only workaround I can offer here.


    I should mention that this only happens with the Intensity Shuttle device--because it is a USB device. It will not happen with the Intensity Pro 4K.

    Cheers,

    Dany
     
  2. Mark Humphrey

    Mark Humphrey New Member

    Joined:
    Nov 5, 2017
    Messages:
    3
    Likes Received:
    0
    I have done everything and made sure everything matches up, but I am getting a blue screen in the Video Manager when selecting the capture. Firewall is also turned off. I am capturing from a Mac using HDMI, could this be the issue?
     
  3. Dany

    Dany Super Moderator

    Joined:
    Jan 16, 2014
    Messages:
    657
    Likes Received:
    61
    Hi Mark,

    Which video capture card are you using?

    Are you also unable to see a preview image after you click the Grab New Video Frame for Preview button?

    Are you able to see the Mac's video output in the capturing utility that came with your capture card?

    What are the video output settings on your Mac, please?


    Thanks,

    Dany


    P.S. The Firewall has nothing to do with the video capture card, so that's irrelevant.
     

Share This Page