1. Welcome to CAST's newly designed and improved Forum

    Log in or Sign up and share the knowledge!

    Dismiss Notice

Mouse scroll wheel behaviour

Discussion in 'wysiwyg' started by Floriaan, Oct 20, 2021.

  1. Floriaan

    Floriaan Well-Known Member

    Joined:
    Feb 13, 2015
    Messages:
    528
    Likes Received:
    109
    Somewhere in the past year, the behavior of the mouse scroll wheel changed. It used to interact with the item or window the mouse hovered over. Now I need to click the field or window where I need to scroll. This causes a lot of extra mouse clicks and erratic scrolls and zooms.

    Example: I have a CAD window open, with a profile selected. I need to adjust pan, tilt and shutters in the Cuts and Adjustments sidebar and also want to zoom in and out a bit in the main CAD window. I used to be able to hover my mouse over the shutters and scroll, now I need to click the shutter and then scroll. This takes a lot more time than before. I would really like this to be changed back.
     
    #1 Floriaan, Oct 20, 2021
    Last edited: Oct 21, 2021
  2. darren powell

    darren powell Super Moderator
    Staff Member

    Joined:
    Mar 8, 2017
    Messages:
    46
    Likes Received:
    6
    Hello Floriaan,


    With regards to clicking before your mouse scroll action: please check that you have enabled ‘Scroll inactive windows when I hover over them” in Windows under Settings>Mouse – with this option enabled you shouldn’t have to click first to activate the window/pane.


    Then try your mouse action and let us know the result.
     
  3. Floriaan

    Floriaan Well-Known Member

    Joined:
    Feb 13, 2015
    Messages:
    528
    Likes Received:
    109
    Thanks a lot. Why don't you consider developing for a proper OS? I hate settings being altered just by auto-updating! This bothered me for a whole year!!!!
    Aaaaand breath in....
    o_O
     

Share This Page