1. Welcome to CAST's newly designed and improved Forum

    Log in or Sign up and share the knowledge!

    Dismiss Notice

Wysiwyg soon crashes after camera switching

Discussion in 'wysiwyg' started by Andrex, Mar 24, 2021.

  1. Andrex

    Andrex New Member

    Joined:
    Mar 4, 2019
    Messages:
    2
    Likes Received:
    0
    Hello community
    I have a big project, imported from a dwg file, it is a complex building with various level, many different rooms, halls, etc.
    When switching to shaded view, if I use only the World camera everything is ok, but anytime I add a camera by drawing it in CAD mode or saving thew current view as a new camera in Shaded view, something goes wrong. When I try to recall that new camera, the application suddendly quit without any notice. The same happens if no layer is visible, so I don't think it is about the complexity of the drawing. (that actually is complex and heavy, the wyg file is about 500MB).
    Here is my computer informations, maybe there is something that I can do about RAM or GPU?
    WYSIWYG Version 1.44.40.22 (Release 44)

    Processor Information:
    - Processor name: Intel(R) Core(TM) i7-5820K CPU @ 3.30GHz
    - Processor vendor: GenuineIntel
    - System type: x64-based PC
    - Number of processors: 12
    - Stock processor speed: ~3298 MHz

    Memory Information:
    - Total physical memory: 32678 megabytes
    - Available physical memory: 21217 megabytes

    Display Information:
    - Display device: AMD FirePro W600
    - Device vendor: ADVANCED MICRO DEVICES, INC.
    - Driver version: 27.20.11027.5002
    - Driver version: 10-27-2020

    Operating System Information:
    - Operating system product: Windows 10 Pro
    - Operating system type: 64-bit
    - Service Pack: N/A

    Any help appreciated, thanks
     
  2. Jason Gardash

    Jason Gardash Active Member

    Joined:
    Feb 5, 2014
    Messages:
    120
    Likes Received:
    13
    Sounds like you may have a corrupted file.

    You do say the file is big and complex building import. It could be the optimization of the building is making the shaded view have issues. If you select object bounding box in the shaded view settings you want to see more blue and cyan boxes over red or yellow boxes.
    If you see more red and yellow's you could try going thru the dwg file to reduce the object counts in the file. it's a pain but works. Doing this currently with the stageline cad's they sent me so my system can get out of the crawl it goes into when I import them.

    It could also be if it is a large file that you spec'd out your system on the file. The Firepro line of cards was a cad type card over a gamers type card if I recall but looking at the specs for it it does render both direct X11 and Opengl 4.2.

    May be worth sending the file to Cast-Soft to have them see if the file was indeed corrupted. or if its an optimization thing.
    send the file to techsupport@cast-soft.com with the dongle number and registered name of the dongle along with what's happening.
    It may take a few days with all this Covid stuff to get a reply but it be faster than waiting for them to request you sending it in via this forum.

    I do see you're on R44 so that may be part of a hiccup (not sure) but if need piece of mind for updating. current deal you get caught up to the new R46 (due in next few weeks) for 1/2 the cost normally.

    Best of luck.
     
  3. darren powell

    darren powell Super Moderator
    Staff Member

    Joined:
    Mar 8, 2017
    Messages:
    30
    Likes Received:
    4
    Hi there
    Please do upload the file to Technical Support so we can investigate the issue further.

    If the file is complex as you say the issue may be with your GPU struggling to display such complexity but we will know more when we receive the file.

    If it’s too large to email just send an email to technical support referencing this issue and I’ll reply with a share file link for you to use for uploading.

    Regards
     
  4. Andrex

    Andrex New Member

    Joined:
    Mar 4, 2019
    Messages:
    2
    Likes Received:
    0
    Thanks Jason and Darren.
    I have worked on the dwg file to reduce polygons and delete unnecessary objects.
    After that work the file was lighter and I was able to work on it. I have also saved different camera views and a camera path, everything seems to work in Design mode. But in CAD mode, shaded view, the behaviour is the same as before: I can move around in World camera but if I switch to a specific saved camera (each of them) , suddendly Wysiwyg quit without any warning or message. I don't think it is about GPU: if my machine can render in real time moving cameras (camera path in Design mode), how is it possible that it doesn't work with a static one? And also what is the difference betwwen shaded view in CAD mode and in Design mode?
    I will send the file to tech support, thank you very much
     

Share This Page